Friday, June 15, 2007


Gobo 3.6 released

Eric Bezault has announced the release of version 3.6 of the Gobo tools and libraries. This release should work with the forthcoming release of ISE's EiffelStudio 6.0.

In response to input from the community, the license has been changed to the permissive MIT license. This license is compatible with many licenses, including the GPL and the Eiffel Forum License. MIT-licensed software can be used within open source and proprietary projects.

The Gobo package no longer contains compiled executables of the basic tools. Instead, a C-package is provided together with scripts to compile it for the target platform.

The package has been tested under Windows XP and Ubuntu Linux. It supports ISE Eiffel 5.6, 5.7 and 6.0 classic and dotNet, plus SmartEiffel 1.2r7. Visual Eiffel support has been dropped, to allow future versions of Gobo to use facilities such as agents that are not supported by VE.

Labels: ,

This page is powered by Blogger. Isn't yours?